]> git.pld-linux.org Git - packages/crossmingw32-libsigc++.git/blame - crossmingw32-libsigc++.spec
do not provide pkgconfig deps in system namespace
[packages/crossmingw32-libsigc++.git] / crossmingw32-libsigc++.spec
CommitLineData
1a9246c6
JB
1Summary: The Typesafe Signal Framework for C++ - MinGW32 cross version
2Summary(pl.UTF-8): Środowisko sygnałów z kontrolą typów dla C++ - wersja skrośna dla MinGW32
67b44d4b
JB
3%define realname libsigc++
4Name: crossmingw32-%{realname}
e27607ce 5Version: 2.2.11
7e12b981 6Release: 3
67b44d4b 7License: LGPL v2.1+
066b4b18 8Group: Development/Libraries
951a73e1 9Source0: http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2/%{realname}-%{version}.tar.xz
e27607ce 10# Source0-md5: 815d0c6d61601f51bbcaeef6826606b0
dec16728 11URL: http://libsigc.sourceforge.net/
12BuildRequires: autoconf >= 2.59
951a73e1 13BuildRequires: automake >= 1:1.9
066b4b18 14BuildRequires: crossmingw32-gcc-c++
e27607ce 15BuildRequires: libtool >= 2:2.0
dec16728 16BuildRequires: m4
1a9246c6 17BuildRequires: mm-common >= 0.7.2
dec16728 18BuildRequires: perl-base
1a9246c6 19BuildRequires: pkgconfig
951a73e1
JB
20BuildRequires: tar >= 1:1.22
21BuildRequires: xz
066b4b18 22Requires: crossmingw32-runtime
dec16728 23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%define no_install_post_strip 1
26
27%define target i386-mingw32
28%define target_platform i386-pc-mingw32
dec16728 29
30%define _sysprefix /usr
31%define _prefix %{_sysprefix}/%{target}
6986ab9d
JB
32%define _libdir %{_prefix}/lib
33%define _pkgconfigdir %{_prefix}/lib/pkgconfig
066b4b18 34%define _dlldir /usr/share/wine/windows/system
dec16728 35%define __cc %{target}-gcc
36%define __cxx %{target}-g++
7e12b981 37%define __pkgconfig_provides %{nil}
dec16728 38
96d9454a
JB
39%ifnarch %{ix86}
40# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
41%define optflags -O2
42%endif
e27607ce 43# -z options are invalid for mingw linker, most of -f options are Linux-specific
96d9454a 44%define filterout_ld -Wl,-z,.*
79081b3a 45%define filterout_c -f[-a-z0-9=]*
e27607ce 46%define filterout_cxx -f[-a-z0-9=]*
96d9454a 47
dec16728 48%description
49This library implements a full callback system for use in widget
50libraries, abstract interfaces, and general programming. Originally
51part of the Gtk-- widget set, libsigc++ is now a seperate library to
52provide for more general use. It is the most complete library of its
53kind with the ablity to connect an abstract callback to a class
54method, function, or function object. It contains adaptor classes for
55connection of dissimilar callbacks and has an ease of use unmatched by
56other C++ callback libraries.
57
1a9246c6 58This package contains cross MinGW32 version.
708b30c2 59
a0719c45
JR
60%description -l pl.UTF-8
61Ta biblioteka jest implementacją pełnego systemu callbacków do
62używania w bibliotekach widgetów, interfejsach abstrakcyjnych i
63ogólnym programowaniu. Oryginalnie była to część zestawu widgetów
64Gtk--, ale jest teraz oddzielną biblioteką ogólniejszego
65przeznaczenia. Jest to kompletna biblioteka tego typu z możliwością
66łączenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
67obiektami funkcji. Zawiera klasy adapterów do łączenia różnych
68callbacków.
dec16728 69
1a9246c6 70Ten pakiet zawiera wersję skrośną MinGW32.
708b30c2 71
066b4b18 72%package static
1a9246c6
JB
73Summary: Static libsigc++ library (cross MinGW32 version)
74Summary(pl.UTF-8): Statyczna biblioteka libsigc++ (wersja skrośna MinGW32)
066b4b18
JB
75Group: Development/Libraries
76Requires: %{name} = %{version}-%{release}
77
78%description static
1a9246c6 79Static libsigc++ library (cross MinGW32 version).
066b4b18
JB
80
81%description static -l pl.UTF-8
1a9246c6 82Statyczna biblioteka libsigc++ (wersja skrośna MinGW32).
066b4b18
JB
83
84%package dll
85Summary: DLL libsigc++ library for Windows
86Summary(pl.UTF-8): Biblioteka DLL libsigc++ dla Windows
87Group: Applications/Emulators
88Requires: wine
89
90%description dll
91DLL libsigc++ library for Windows.
92
93%description dll -l pl.UTF-8
94Biblioteka DLL libsigc++ dla Windows.
95
dec16728 96%prep
67b44d4b 97%setup -q -n %{realname}-%{version}
dec16728 98
99%build
100%{__libtoolize}
1a9246c6 101%{__aclocal} -I build
dec16728 102%{__autoconf}
103%{__automake}
104%configure \
178e282c 105 --target=%{target} \
106 --host=%{target} \
178e282c 107 --enable-static
108
dec16728 109%{__make} all
110
111%install
112rm -rf $RPM_BUILD_ROOT
113
114%{__make} install \
115 DESTDIR=$RPM_BUILD_ROOT
116
066b4b18
JB
117install -d $RPM_BUILD_ROOT%{_dlldir}
118mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
119
120%if 0%{!?debug:1}
121%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
122%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
123%endif
124
1a9246c6 125%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{devhelp,doc}
066b4b18 126
dec16728 127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%files
131%defattr(644,root,root,755)
132%doc AUTHORS ChangeLog NEWS README TODO
066b4b18
JB
133%{_libdir}/libsigc-2.0.dll.a
134%{_libdir}/libsigc-2.0.la
135%{_libdir}/sigc++-2.0
723599ec 136%{_includedir}/sigc++-2.0
67b44d4b 137%{_pkgconfigdir}/sigc++-2.0.pc
066b4b18
JB
138
139%files static
140%defattr(644,root,root,755)
141%{_libdir}/libsigc-2.0.a
142
143%files dll
144%defattr(644,root,root,755)
145%{_dlldir}/libsigc-2.0-*.dll
This page took 0.126788 seconds and 4 git commands to generate.